Dan English's BI Blog

Welcome to my random thoughts in regards to Business Intelligence, databases, and other technologies

Archive for April 1st, 2009

PerformancePoint Dashboard Designer ‘Unable to connect to server’ with SSRS 2008

Posted by denglishbi on April 1, 2009

This was a rather odd one that I ran into and still a little puzzled with this, but once again there is a workaround and I will get to that in a bitNerd

So we upgraded to Reporting Services (SSRS) 2008 and got PerformancePoint Server (PPS) upgraded to SP2, installed the latest SQL 2005 components needed, and installed the Microsoft Report Viewer Redistributable 2008.  We started to work with some SQL Server Report Items in Dashboard Designer and ran into an issue with some of them.  The message we were getting when trying to reference the reports in ‘Report Center’ mode in Dashboard Designer (why is this called Report Center…very confusing when this actually means Native mode) was ‘Unable to connect to server’.

PPS_unable_to_connect_SSRS2008

What does that even mean?  I can browse the report library and select the report, but I get this pop-up message after I select the report i want to reference.  Then we notice that the Parameters are not being pulled into the Dashboard Designer report item (or just a couple are)…what is going on?  How can we link the dashboard filters to endpoints without the parameters?

I checked security permission on the SSRS server and retried this using SSRS 2005 and everything seemed to be in check, but we want to use SSRS 2008.  I even used .NET Reflector on all of the PPS dlls to try and track down this error, but I was unsuccessful in locating it.  It is definitely related to SSRS 2008 since we never had issues with SSRS 2005 and it seems to happen mainly with reports that don’t have a default value set for parameters.

Just for giggles I tried the old pre-PPS SP2 workaround to reference SSRS 2008 reports, Performance Point Server – Integrating SSRS2008 Report View, which is to basically tell Dashboard Designer that you are using ‘SharePoint Integrated’ mode instead (even though you are just using Native mode).  And what do you know, it works just fine and pulls in all of the report parameters.  The only issue with that is that you don’t get the nice browse feature to select the report that you want to reference, but it works and that is what is important.

So after all of the testing, validation, trial-and-error, etc. I posted a question to the forums which ends up in another Microsoft case ticket which is currently with the PPS Team and being worked on for a potential hotfix.

PPS SQL Server Report (SSRS 2008) ‘Unable to connect to server’

UPDATE (5/2/2009):  A hotfix has been made available for this fix here – Description of the PerformancePoint Server 2007 hotfix package: April 28, 2009.  Check out my recent blog posting here PerformancePoint Server 2007 Hotfixes Available and Build List.

Posted in PerformancePoint | Tagged: , | 4 Comments »